php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56385 compile error with latest tarball from sf.net
Submitted: 2005-05-01 21:55 UTC Modified: 2005-05-02 07:05 UTC
From: alan at akbkhome dot com Assigned:
Status: Closed Package: colorer (PECL)
PHP Version: 5_1 CVS-2005-05-01 (dev) OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alan at akbkhome dot com
New email:
PHP Version: OS:

 

 [2005-05-01 21:55 UTC] alan at akbkhome dot com
Description:
------------
getting this with CVS against the last package from sourceforge. (changing validate to (-1, false), on that line builds ok though..)

/usr/src/pecl/colorer/colorer.cpp: In function `int colorer_do_highlight(int,
   zval*, zval*, int, colorer_t*, LineStore*, String*, String*, char*, zval*)':
/usr/src/pecl/colorer/colorer.cpp:569: error: no matching function for call to
   `BaseEditor::validate(int)'
/usr/include/colorer/colorer/editor/BaseEditor.h:180: error: candidates are:
   void BaseEditor::validate(int, bool)



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-02 07:05 UTC] demenev at gmail dot com
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/colorer


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon May 27 03:01:26 2019 UTC