php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56371 Can save big data
Submitted: 2005-04-10 04:44 UTC Modified: 2005-04-10 16:44 UTC
From: ap at tellusion dot com Assigned:
Status: Not a bug Package: memcache (PECL)
PHP Version: 5.0.3 OS: Linux Rehat EL
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ap at tellusion dot com
New email:
PHP Version: OS:

 

 [2005-04-10 04:44 UTC] ap at tellusion dot com
Description:
------------
Can't save big data (1779085 bytes serialized), the server has tons of free space left (~2GB). The key I'm using is 'loadObjectList5187dd6b7f95f74a6577f4be9611cbbf', $memcache->set() just fails, regardless of the timeout & compression flag settings (present or not).

Reproduce code:
---------------
Array
                (
                    [failed save] => loadObjectList5187dd6b7f95f74a6577f4be9611cbbf
                    [length] => 1779085
                )



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-10 16:31 UTC] tony2001 at phpclub dot net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PECL.


Please provide at least some reproduce code.
Also, more detailed description would be good too.
 [2005-04-10 16:33 UTC] ap at tellusion dot com
bit more info. Seems that the the server has a limit on the size of key/value pairs. On big values the server is generating "SERVER_ERROR out of memory", even though the server has hundreds of megs free.
 [2005-04-10 16:44 UTC] tony2001 at phpclub dot net
Then it's definitely not a bug of PECL/memcache.
Please reopen the rpport if you find any additional info.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 14:03:18 2021 UTC