php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56344 PEAR Manual en/fr show session_start() error and breaks IE completely
Submitted: 2005-03-09 20:41 UTC Modified: 2005-03-10 08:48 UTC
From: davey@php.net Assigned: mj (profile)
Status: Not a bug Package: PECL website (PECL)
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: davey@php.net
New email:
PHP Version: OS:

 

 [2005-03-09 20:41 UTC] davey@php.net
Description:
------------
The English and French manuals both show the following error BUT only if you're NOT logged in:

<br />
<b>Warning</b>:  session_start(): The session id contains invalid characters, valid characters are only a-z, A-Z and 0-9 in <b>/usr/local/www/pearweb/include/pear-prepend.php</b> on line <b>98</b><br />

Now, because the page has a <?xml ?> tag in it, IE will always try to read it as XML regardless of the text/html content type or not, thus:

The XML page cannot be displayed 
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later. 


--------------------------------------------------------------------------------

Only one top level element is allowed in an XML document. Error processing resource 'http://pear.php.net/manual/en/'. Line...

<b>Warning</b>:  session_start(): The session id contains invalid characters, valid characters are only a-z, A-Z...

The error itself doesn't seem to have a reason, its a simple session_start() and I see nothing setting an alternate session_id... 

- Davey


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-10 05:54 UTC] mj@php.net
I can't reproduce this.  Anyone else?
 [2005-03-10 07:22 UTC] mike@php.net
Nope
 [2005-03-10 08:48 UTC] mj@php.net
Closing this.  Davey, if you get this error again, please post the time of the request (and IP if possible) so that we can look it up in the access logs et al.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jun 24 16:01:26 2019 UTC