php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56343 Prepared statements with ? as placeholder doesn't work
Submitted: 2005-03-08 22:19 UTC Modified: 2005-10-23 09:27 UTC
From: magnus@php.net Assigned:
Status: No Feedback Package: PDO_OCI (PECL)
PHP Version: 5_1 CVS-2005-03-08 (dev) OS: Linux (Gentoo current)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
46 + 15 = ?
Subscribe to this entry?

 
 [2005-03-08 22:19 UTC] magnus@php.net
Description:
------------
Prepared statements with ? doesn't work with the OCI driver.


Reproduce code:
---------------
<?php
$DB = new pdo("oci:dbname=DATABASE", "user", "password");
$stmt = $DB->prepare('INSERT INTO test VALUES(?, ?, ?)');
$stmt->execute(array("1", "2", "3"));
var_dump($stmt->errorInfo());
?>

Actual result:
--------------
array(3) {
  [0]=>
  string(5) "HY000"
  [1]=>
  int(1036)
  [2]=>
  string(108) "OCIBindByPos: ORA-01036: illegal variable name/number
 (/mnt/data5/PHP/head/ext/pdo_oci/oci_statement.c:260)"
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-10 02:25 UTC] wez@php.net
Please try latest CVS and let me know if this is still an issue.
 [2005-10-23 09:27 UTC] mike@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 03:05:52 2022 UTC