php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56325 statgrab-0.3 fails to ./configure
Submitted: 2005-02-23 17:51 UTC Modified: 2005-04-05 23:42 UTC
From: neuhauser at chello dot cz Assigned:
Status: Closed Package: statgrab (PECL)
PHP Version: 5.0.3 OS: FreeBSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: neuhauser at chello dot cz
New email:
PHP Version: OS:

 

 [2005-02-23 17:51 UTC] neuhauser at chello dot cz
Description:
------------
there are two problems:

* the linker doesn't like -ldl
* config.m4 doesn't add $STATGRAB_DIR/include to the list of include dirs

fix for the second problem can be found in this patch:
http://codex.sigpipe.cz/~smradoch/FreeBSD/ports/sysutils/pecl-statgrab/files/patch-aa-config.m4

Reproduce code:
---------------
checking for sg_init in -lstatgrab... no
configure: error: wrong libstatgrab version or lib not found, Statgrab version 0.10+ is required.

config.log:

configure:2599: cc -o conftest -O -pipe -march=k6  -R/usr/local/lib -L/usr/loca>
/usr/libexec/elf/ld: cannot find -ldl

and for the missing -I$STATGRAB_DIR/include

/usr/home/roman/codex/FreeBSD/ports/sysutils/pecl-statgrab/work/Statgrab-0.3/statgrab.c:25: statgrab.h: No such file or directory



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-23 17:56 UTC] neuhauser at chello dot cz
urm, I should have also noted that I needed to use

LIBS="-lkvm -ldevstat" ./configure

to get it to create the Makefile. This is on FreeBSD 4.10-STABLE i386.
 [2005-03-24 05:59 UTC] neuhauser at chello dot cz
the patch is now at http://codex.sigpipe.cz/FreeBSD/ports/sysutils/pecl-statgrab/files/patch-aa-config.m4
 [2005-04-05 11:17 UTC] ilia at prohost dot org
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 [2005-04-05 18:35 UTC] neuhauser at chello dot cz
the change you committed lets the configure check succeed, but build fails. please commit also this change:

+    PHP_ADD_INCLUDE($STATGRAB_DIR/include)

reopening because the bug has not been fixed.
 [2005-04-05 23:42 UTC] ilia at prohost dot org
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Dec 05 03:01:23 2020 UTC