php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56299 ssh_sftp timeout
Submitted: 2005-02-14 09:10 UTC Modified: 2005-10-23 10:03 UTC
From: robert dot beenen at philips dot com Assigned: mike (profile)
Status: Closed Package: ssh2 (PECL)
PHP Version: 4.3.10 OS: Solaris 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
34 - 22 = ?
Subscribe to this entry?

 
 [2005-02-14 09:10 UTC] robert dot beenen at philips dot com
Description:
------------
Using ssh2_sftp_-functions result in timeout.
The call to ssh2_sftp returns a resource, but when a call to a ssh2_sftp_...-function results in a script timeout.

Reproduce code:
---------------
$sftp = ssh2_sftp($connection);
$statinfo = ssh2_sftp_realpath($sftp, $path);


Actual result:
--------------
A php timeout on ssh2_sftp_realpath.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-22 02:41 UTC] robert dot beenen at philips dot com
I have installed version 0.7 of libssh2, rebuild php with ssh2 0.6, but the script still times out.
 [2005-02-25 07:55 UTC] robert dot beenen at philips dot com
Just did a rebuild of php with version 0.7 of both ssh2 and libssh2.
The test-script still times out on the first action after the ssh2_sftp call.
 [2005-05-18 00:49 UTC] pollita@php.net
Please try out libssh2 version 0.10
 [2005-05-25 08:28 UTC] robert dot beenen at philips dot com
I get the following errors while trying to compile php 4.3.10 with the ssh2 0.8 extension:
ssh2_fopen_wrappers.c:In function `php_ssh2_channel_stream_set_option':
ssh2_fopen_wrappers.c:85: error: `PHP_STREAM_OPTION_CHECK_LIVENESS' undeclared (first use in this function)
ssh2_fopen_wrappers.c:85: error: (Each undeclared identifier is reported only once
ssh2_fopen_wrappers.c:85: error: for each function it appears in.)
make: *** [ext/ssh2/ssh2_fopen_wrappers.lo] Error 1
 [2005-05-25 10:35 UTC] pollita@php.net
Yes, that's coming back to bite me repeatedly.  There's a fix that I didn't test against 4.3.x (and it turns out I should have).

Edit the source of ssh2_fopen_wrappers.c and comment out lines 85 through 87 and it'll compile fine.  PHP4 doesn't need that block anyway.

If that's more work than you signed up for (since it involves performing manual PECL bulid steps), you can just wait for the next release which I'm rolling fairly soon anyway.
 [2005-05-27 04:20 UTC] robert dot beenen at philips dot com
I have applied that fix and tried again.
It is working fine now. The timeout problem is gone and i can transfer files using this extension.
 [2005-10-23 10:03 UTC] mike@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Dec 13 21:01:24 2019 UTC