php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #56226 Failure to load after install
Submitted: 2004-11-05 23:13 UTC Modified: 2015-08-25 13:33 UTC
From: abbaddon at smartchat dot net dot au Assigned: cmb (profile)
Status: Closed Package: mailparse (PECL)
PHP Version: 4.3.3 OS: Linux Fedora core 1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
12 + 7 = ?
Subscribe to this entry?

 
 [2004-11-05 23:13 UTC] abbaddon at smartchat dot net dot au
Description:
------------
Note - php version is actually 4.39 (wasnt an option above)
OS FedoreCore1
mbstring IS listed and working in extensions

Installation seemed to go as expected, however when I executed a script to check the existance of mailparse (or load it if it wasnt already) I received this error
dl(): Unable to load dynamic library '/usr/lib/php4/mailparse.so' - /usr/lib/php4/mailparse.so: undefined symbol: mbfl_convert_filter_new

Mailparse does not appear in the list of installed modules vie extension=mailparse.so
The .so is in /usr/lib/php4/ with the other extensions

manual installation does not resolve this problem

ie 
1. download mailparse package
2. phpize configure make make install reports sucessful installation

still the same error

Reproduce code:
---------------
echo "testing for mailparse<br>";
if(extension_loaded("mailparse")) {
        echo "mailparse is detected by extension_loaded<br>";
} else {
        echo "mailparse is ***NOT** detected by extension_loaded - it has to be loaded via dl function<br>";
                dl("mailparse.so");
}

if (function_exists('mailparse_rfc822_parse_addresses'))
    		echo "mailparse exists<br>";


Expected result:
----------------
"mailparse exists"

Actual result:
--------------
testing for mailparse
mailparse is ***NOT** detected by extension_loaded - it has to be loaded via dl function
Error of type E_WARNING: dl(): Unable to load dynamic library '/usr/lib/php4/mailparse.so' - /usr/lib/php4/mailparse.so: undefined symbol: mbfl_convert_filter_new


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-06-03 04:03 UTC] bugs dot pear dot php dot net at tylerrick dot com
What worked for me, strangely, was what it suggested in http://www.cerb4.com/forums/showthread.php?t=40 --

In /etc/php.d/mbstring.ini : changed from
extension=mbstring.so

to:
extension=mbstring.so
extension=mailparse.so

Not sure why that would fix it ... but I'm guessing the problem was simply that mbstring.so needed to get loaded first.

> php --version
PHP 5.1.6 (cli) (built: Oct 26 2007 13:49:00) 

> uname -a
Linux ...  2.6.9-023stab046.2-enterprise #1 SMP Mon Dec 10 15:22:33 MSK 2007 i686 athlon i386 GNU/Linux
 [2015-08-25 13:24 UTC] cmb@php.net
-Status: Open +Status: Verified -Type: Bug +Type: Documentation Problem -Assigned To: +Assigned To: cmb
 [2015-08-25 13:24 UTC] cmb@php.net
Indeed, mbstring has to be loaded before mailparse.
 [2015-08-25 13:32 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=337624
Log: mailparse requires mbstring (fixes #56226)
 [2015-08-25 13:33 UTC] cmb@php.net
-Status: Verified +Status: Closed
 [2015-08-25 13:33 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Aug 24 13:01:27 2019 UTC