php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56210 Ability to specify alias for main table
Submitted: 2004-10-05 07:18 UTC Modified: 2015-03-25 21:05 UTC
From: pecl-dbdo-bug-2004 at ryandesign dot com Assigned:
Status: Not a bug Package: DBDO (PECL)
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: pecl-dbdo-bug-2004 at ryandesign dot com
New email:
PHP Version: OS:

 

 [2004-10-05 07:18 UTC] pecl-dbdo-bug-2004 at ryandesign dot com
Description:
------------
In the PEAR version of DB_DataObjects, I can give
an alias to a joined table like this:

$main_table = DB_DataObject::factory('main_table');
$joined_table = DB_DataObject::factory('joined_table');
$main_table->joinAdd($joined_table, '', 'jt');

The generated SQL then starts like this:

SELECT * FROM main_table, joined_table AS jt

I want to generate the following SQL instead:

SELECT * FROM main_table AS mt, joined_table AS jt

But this capability does not exist in the PEAR module.
I presume the same limitations currently exist in the
PECL version.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-03-25 21:05 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2015-03-25 21:05 UTC] cmb@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Nov 29 18:05:52 2022 UTC