php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56207 non-existing functions
Submitted: 2004-10-01 11:49 UTC Modified: 2004-11-29 19:59 UTC
From: christian at wenz dot org Assigned: hholzgra (profile)
Status: Closed Package: PECL_Gen (PECL)
PHP Version: Irrelevant OS: irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: christian at wenz dot org
New email:
PHP Version: OS:

 

 [2004-10-01 11:49 UTC] christian at wenz dot org
Description:
------------
the current release of PECL_Gen, as well as the current CVS version, do reference non-existing functions because the studlyCaps conversion was not completely done in Extension.php and License.php.

Recommended fix:

1) Extension.php, line 971: replace
  $code.= $this->license->license_comment();
by
  $code.= $this->license->getComment();

2) License.php, line 77: replace
  fputs($fp, $this->license_file_text());
by
  fputs($fp, $this->license_getText());


Reproduce code:
---------------
pecl-gen any.xml

Expected result:
----------------
no error

Actual result:
--------------
error that function license_comment() was not found / that function license_file_text() was not found

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-11-29 19:59 UTC] hholzgra@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 02:01:23 2020 UTC