php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56206 apd make install breaks
Submitted: 2004-10-01 08:40 UTC Modified: 2004-12-14 10:11 UTC
From: loop at superinfinite dot com Assigned:
Status: Not a bug Package: apd (PECL)
PHP Version: 5.0.0b1 (beta1) OS: Mac OS X 10.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: loop at superinfinite dot com
New email:
PHP Version: OS:

 

 [2004-10-01 08:40 UTC] loop at superinfinite dot com
Description:
------------
Either through pear install apd, or compiling manually, the following error 
message is produced:

gcc -I. -I/Users/bartz/Desktop/apd-1.0.1 -DPHP_ATOM_INC -I/Users/
bartz/Desktop/apd-1.0.1/include -I/Users/bartz/Desktop/apd-1.0.1/main 
-I/Users/bartz/Desktop/apd-1.0.1 -I/usr/include/php -I/usr/include/php/
main -I/usr/include/php/Zend -I/usr/include/php/TSRM 
-DHAVE_CONFIG_H -g -O2 -c /Users/bartz/Desktop/apd-1.0.1/php_apd.c  
-fno-common -DPIC -o .libs/php_apd.o
/Users/bartz/Desktop/apd-1.0.1/php_apd.c: In function 
`apd_get_active_function_name':
/Users/bartz/Desktop/apd-1.0.1/php_apd.c:305: error: invalid operands 
to binary !=
/Users/bartz/Desktop/apd-1.0.1/php_apd.c:306: error: invalid type 
argument of `unary *'
/Users/bartz/Desktop/apd-1.0.1/php_apd.c:312: error: structure has no 
member named `scope'
/Users/bartz/Desktop/apd-1.0.1/php_apd.c:313: error: structure has no 
member named `scope'
/Users/bartz/Desktop/apd-1.0.1/php_apd.c: At top level:
/Users/bartz/Desktop/apd-1.0.1/php_apd.c:470: error: `OnUpdateLong' 
undeclared here (not in a function)
/Users/bartz/Desktop/apd-1.0.1/php_apd.c:470: error: initializer element 
is not constant
/Users/bartz/Desktop/apd-1.0.1/php_apd.c:470: error: (near 
initialization for `ini_entries[1].on_modify')
/Users/bartz/Desktop/apd-1.0.1/php_apd.c:470: error: initializer element 
is not constant
/Users/bartz/Desktop/apd-1.0.1/php_apd.c:470: error: (near 
initialization for `ini_entries[1]')
/Users/bartz/Desktop/apd-1.0.1/php_apd.c:471: error: initializer element 
is not constant
/Users/bartz/Desktop/apd-1.0.1/php_apd.c:471: error: (near 
initialization for `ini_entries[2]')
make: *** [php_apd.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-25 21:55 UTC] william at komodocms dot com
I get exactly the same problem on Fedora Core 2 running PHP 4.3.8 and APD 1.0.1 when we run the make command.  Any assistance would be greatly appreciated.

----------------------------------------------------------
/bin/sh /build/apd-1.0.1/libtool --mode=compile gcc  -I. -I/build/apd-1.0.1 -DPHP_ATOM_INC -I/build/apd-1.0.1/include -I/build/apd-1.0.1/main -I/build/apd-1.0.1 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM  -DHAVE_CONFIG_H  -g -O2  -prefer-pic -c /build/apd-1.0.1/php_apd.c -o php_apd.lo
 gcc -I. -I/build/apd-1.0.1 -DPHP_ATOM_INC -I/build/apd-1.0.1/include -I/build/apd-1.0.1/main -I/build/apd-1.0.1 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -DHAVE_CONFIG_H -g -O2 -c /build/apd-1.0.1/php_apd.c  -fPIC -DPIC -o .libs/php_apd.o
/build/apd-1.0.1/php_apd.c: In function `apd_get_active_function_name':
/build/apd-1.0.1/php_apd.c:305: error: invalid operands to binary !=
/build/apd-1.0.1/php_apd.c:306: error: invalid type argument of `unary *'
/build/apd-1.0.1/php_apd.c:312: error: structure has no member named `scope'
/build/apd-1.0.1/php_apd.c:313: error: structure has no member named `scope'
/build/apd-1.0.1/php_apd.c: At top level:
/build/apd-1.0.1/php_apd.c:470: error: `OnUpdateLong' undeclared here (not in a function)
/build/apd-1.0.1/php_apd.c:470: error: initializer element is not constant
/build/apd-1.0.1/php_apd.c:470: error: (near initialization for `ini_entries[1].on_modify')
/build/apd-1.0.1/php_apd.c:470: error: initializer element is not constant
/build/apd-1.0.1/php_apd.c:470: error: (near initialization for `ini_entries[1]')
/build/apd-1.0.1/php_apd.c:471: error: initializer element is not constant
/build/apd-1.0.1/php_apd.c:471: error: (near initialization for `ini_entries[2]')
make: *** [php_apd.lo] Error 1
 [2004-12-14 09:52 UTC] ssgro at blueprint dot org
Same experience with solaris 9/gcc 3.3.2.
 [2004-12-14 10:11 UTC] gschlossnagle@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

0.9 series works with PHP4, 1.0 series works with PHP5; 
you're building on the wrong platform.  If you have a 
problem building the the corresponding versions, please 
feel free to reopen.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Sep 25 10:01:23 2020 UTC