php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56162 sqlite compile fails
Submitted: 2004-08-10 18:07 UTC Modified: 2004-09-08 05:43 UTC
From: drudge at linuxworkbench dot com Assigned:
Status: Not a bug Package: SQLite (PECL)
PHP Version: 5.0 OS: freebsd
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: drudge at linuxworkbench dot com
New email:
PHP Version: OS:

 

 [2004-08-10 18:07 UTC] drudge at linuxworkbench dot com
Description:
------------
=[NOC][root] /usr/ports/devel/libtool13 > pear install SQLite 
downloading SQLite-1.0.3.tar ... 
Starting to download SQLite-1.0.3.tar (-1 bytes) 
.................................................................................done: 1,539,072 bytes 
50 source files, building 
running: phpize 
Configuring for: 
PHP Api Version:         20031224 
Zend Module Api No:      20040412 
Zend Extension Api No:   220040412 
autoheader: `config.h.in' is created 
building in /var/tmp/pear-build-root/SQLite-1.0.3 
running: /tmp/tmplGVbsi/SQLite-1.0.3/configure 
checking build system type... i386-unknown-freebsd5.2.1 
checking host system type... i386-unknown-freebsd5.2.1 
checking for gcc... gcc 
checking for C compiler default output... a.out 
checking whether the C compiler works... yes 
checking whether we are cross compiling... no 
checking for suffix of executables... 
checking for suffix of object files... o 
checking whether we are using the GNU C compiler... yes 
checking whether gcc accepts -g... yes 
checking whether gcc and cc understand -c and -o together... yes 
checking if compiler supports -R... yes 
checking for PHP prefix... /usr/local 
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM 
checking for PHP extension directory... /usr/local/lib/php/extensions/no-debug-non-zts-20040412 
checking for re2c... exit 0; 
checking for gawk... no 
checking for mawk... no 
checking for nawk... nawk 
checking for sqlite support... yes, shared 
checking how to run the C preprocessor... gcc -E 
checking for ANSI C header files... yes 
checking for sys/types.h... yes 
checking for sys/stat.h... yes 
checking for stdlib.h... yes 
checking for string.h... yes 
checking for memory.h... yes 
checking for strings.h... yes 
checking for inttypes.h... yes 
checking for stdint.h... yes 
checking for unistd.h... yes 
checking for char *... yes 
checking size of char *... 4 
checking for usleep... yes 
checking for nanosleep... yes 
checking time.h usability... yes 
checking time.h presence... yes 
checking for time.h... yes 
checking for ld used by GCC... /usr/bin/ld 
checking if the linker (/usr/bin/ld) is GNU ld... yes 
checking for /usr/bin/ld option to reload object files... -r 
checking for BSD-compatible nm... /usr/bin/nm -B 
checking for a sed that does not truncate output... /usr/bin/sed 
checking whether ln -s works... yes 
checking how to recognise dependent libraries... pass_all 
checking command to parse /usr/bin/nm -B output... ok 
checking dlfcn.h usability... yes 
checking dlfcn.h presence... yes 
checking for dlfcn.h... yes 
checking for ranlib... ranlib 
checking for strip... strip 
checking for objdir... .libs 
checking for gcc option to produce PIC... -fPIC 
checking if gcc PIC flag -fPIC works... yes 
checking if gcc static flag -static works... yes 
checking if gcc supports -c -o file.o... yes 
checking if gcc supports -c -o file.lo... yes 
checking if gcc supports -fno-rtti -fno-exceptions... yes 
checking whether the linker (/usr/bin/ld) supports shared libraries... yes 
checking how to hardcode library paths into programs... immediate 
checking whether stripping libraries is possible... yes 
checking dynamic linker characteristics... freebsd5.2.1 ld.so 
checking if libtool supports shared libraries... yes 
checking whether to build shared libraries... yes 
checking whether to build static libraries... no 
checking whether -lc should be explicitly linked in... yes 
creating libtool 
configure: creating ./config.status 
config.status: creating config.h 
running: make 
/bin/bash /var/tmp/pear-build-root/SQLite-1.0.3/libtool --mode=compile gcc -I/tmp/tmplGVbsi/SQLite-1.0.3/libsqlite/src -I. -I/tmp/tmplGVbsi/SQLite-1.0.3 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/SQLite-1.0.3/include -I/var/tmp/pear-build-root/SQLite-1.0.3/main -I/tmp/tmplGVbsi/SQLite-1.0.3 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM  -DHAVE_CONFIG_H  -g -O2  -prefer-pic -c /tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c -o sqlite.lo 
gcc -I/tmp/tmplGVbsi/SQLite-1.0.3/libsqlite/src -I. -I/tmp/tmplGVbsi/SQLite-1.0.3 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/SQLite-1.0.3/include -I/var/tmp/pear-build-root/SQLite-1.0.3/main -I/tmp/tmplGVbsi/SQLite-1.0.3 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -DHAVE_CONFIG_H -g -O2 -c /tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c  -fPIC -DPIC -o sqlite.lo 
/tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c:56: error: `BYREF_NONE' undeclared here (not in a function) 
/tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c:56: error: initializer element is not constant 
/tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c:56: error: (near initialization for `arg3_force_ref[1]') 
/tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c:56: error: `BYREF_NONE' undeclared here (not in a function) 
/tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c:56: error: initializer element is not constant 
/tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c:56: error: (near initialization for `arg3_force_ref[2]') 
/tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c:56: error: `BYREF_FORCE' undeclared here (not in a function) 
/tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c:56: error: initializer element is not constant 
/tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c:56: error: (near initialization for `arg3_force_ref[3]') 
/tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c:125: warning: initialization from incompatible pointer type 
/tmp/tmplGVbsi/SQLite-1.0.3/sqlite.c:126: warning: initialization from incompatible pointer type 
*** Error code 1 

Stop in /var/tmp/pear-build-root/SQLite-1.0.3. 
`make' failed


Expected result:
----------------
to be compiled :(

Actual result:
--------------
errors

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-14 12:12 UTC] bray at sent dot com
I found this bug report concerning shtool and 
libtoolize.

http://bugs.php.net/bug.php?id=27245

So, it looks like a freebsd problem. And I see you use 
libtool13. However, I was unable to get this to build 
unless I used libtoolize (GNU libtool) 1.5

[mia] $ sudo ln -s /usr/bin/glibtoolize /usr/bin/
libtoolize
[mia] $ sudo pear install SQLite
 [2004-09-08 05:16 UTC] strauchdieb at gmx dot de
Changing the libtool version doesn't work for me on Mac 
OS X.
I'm using version 1.5 of libtoolize (GNU libtool).
 [2004-09-08 05:43 UTC] wez@php.net
You're compiling the PHP 4.3 version of sqlite against PHP 5 (as can be seen from the phpize output), which already has it built-in.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Dec 14 16:01:23 2019 UTC