php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56140 mailparse hangs on content-id
Submitted: 2004-07-22 07:06 UTC Modified: 2015-03-23 20:03 UTC
From: sk at xib dot com Assigned:
Status: Not a bug Package: mailparse (PECL)
PHP Version: Irrelevant OS: suse 9.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sk at xib dot com
New email:
PHP Version: OS:

 

 [2004-07-22 07:06 UTC] sk at xib dot com
Description:
------------
Mailparse hangs when message-id looks like: <nnnn>:<nnnn>


You can reproduce wich this message http://domtainer.net/errormail.msg



Reproduce code:
---------------
http://domtainer.net/errormail.msg

Expected result:
----------------
 $info = mailparse_msg_get_part_data($section);

return with values,

Actual result:
--------------
 $info = mailparse_msg_get_part_data($section);

hangs till cpu-timelimit kills php.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-03-23 20:03 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2015-03-23 20:03 UTC] cmb@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 23 11:03:34 2021 UTC