php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56093 Column names still mangled
Submitted: 2004-06-10 20:49 UTC Modified: 2004-06-11 04:38 UTC
From: rjl26 at email dot byu dot edu Assigned:
Status: Not a bug Package: SQLite (PECL)
PHP Version: 4.3.3 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rjl26 at email dot byu dot edu
New email:
PHP Version: OS:

 

 [2004-06-10 20:49 UTC] rjl26 at email dot byu dot edu
Description:
------------
When selecting columns using the <table>.<columname> the results name the column "<table>.<columname>".  This could be considered correct except that it is different from every other database binding.

Reproduce code:
---------------
$rs = sqlite_query("select stuff.name from stuff where stuff.id = 1",$connection);

print_r(sqlite_fetch_array($rs, SQLITE_ASSOC));


Expected result:
----------------
array(
     [name] => "name"
)

Actual result:
--------------
array(
     [stuff.name] => "name"
)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-11 04:38 UTC] wez@php.net
That's just how sqlite works; go report it to them if you think it is wrong.
Not a bug in PHP or the PHP bindings.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 14 16:01:42 2019 UTC