php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56070 Fails to Install
Submitted: 2004-05-20 11:07 UTC Modified: 2015-03-23 19:52 UTC
From: iwarner at triangle-solutions dot com Assigned:
Status: Not a bug Package: mailparse (PECL)
PHP Version: 5CVS-2004-05-20 (dev) OS: Win XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: iwarner at triangle-solutions dot com
New email:
PHP Version: OS:

 

 [2004-05-20 11:07 UTC] iwarner at triangle-solutions dot com
Description:
------------
I am trying to install this on winXP PHP 5.0.0 RC2

c:/php/ pear install mailparse

It downloads fine

It errors with 'mbstring not installed' - however this is installed and I get no errors of php to state otherwise.

On PHP 4.3x I get an error saying mailparse.dsp does not exist?

Help appreciated


Reproduce code:
---------------
C:\PHP>pear install mailparse
downloading mailparse-2.0b.tgz ...
Starting to download mailparse-2.0b.tgz (33,547 bytes)
.........done: 33,547 bytes
9 source files, building
The DSP mailparse.dsp does not exist.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-11-16 01:15 UTC] john at jbwalker dot com
I believe there is a weakness in the documentation at http://php.net/manual/en/mbstring.installation.php and, not wishing to start a new bug, I felt that this bug was the closest to the problem I've noticed.

Running Windows 7 on a Lenovo laptop with an almost identical parallel AMP setup on a Toshiba laptop. The "almost" means that httpd.conf and php.ini were identical except that Apache and PHP were installed in different locations on the two computers (the config files reflected that; the problems below were NOT a result of errors in the configuration).

Initial setup of phpMyAdmin failed on the Lenovo because apparently mbstring couldn't be found. Yet the same php.ini worked on the Toshiba. Eventually noticed that in phpinfo, other extensions were not working either on the Lenovo but were working on the Toshiba. I eventually solved the problem by commenting out the tmp_upload_dir in httpd.conf for Apache (because I noticed that in phpinfo for the Lenovo, the php.ini seemed to be listed in its entirety on the entry for tmp_upload_dir).

Obviously this is a voodoo solution and needs further investigation. I've no idea why the solution would have anything to do with the problem observed but apparently something in httpd.conf resulted in the extensions directory not being found (extensions_dir is defined). 

But the point is that this mbstring problem seems to come up fairly often (I had it several years ago) and are not answered elsewhere on the web. I believe that the base problem is that extensions directory is sometimes not found and yet there is no error message to this effect.

Ideally this would be documented on php.net at the link above. This link appears to only describe the install/compile. It makes no mention of the extension, which is provided by default on Windows systems these days.

Hope this is helpful.
 [2015-03-23 19:52 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2015-03-23 19:52 UTC] cmb@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

PS: @john

> not wishing to start a new bug

It doesn't make much sense, though, to add an only slightly related
(if at all) comment to a nearly ten year old bug report. If you
feel that your problem has not been addressed properly in the
meantime, please open a new bug report.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 23 10:03:34 2021 UTC