php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5607 Variables missing within require code
Submitted: 2000-07-15 11:37 UTC Modified: 2000-08-08 23:03 UTC
From: mikro at nextra dot sk Assigned:
Status: Closed Package: Other
PHP Version: 4.0.1pl2 OS: MS Windows NT 4.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mikro at nextra dot sk
New email:
PHP Version: OS:

 

 [2000-07-15 11:37 UTC] mikro at nextra dot sk
When I define variable within included part of code than my variable is not visible in fuctions within included part.

Example:

.
.
.
require(foo.php)
.
.
.


[foo.php]
.
.
.
$variable="something";
.
.
.
here is variable visible
.
.
function Foo(){
global $variable;
.
.
here is variable not visible for some strange reasons.
.
.
}


please check this situation.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-17 06:42 UTC] stas at cvs dot php dot net
Please provide runnable reproducing code.
 [2000-08-08 23:03 UTC] waldschrott@php.net
Closed due to missing user feedback.
 [2002-02-19 05:23 UTC] hvalette at free dot fr
Hi,

I looked for fix of the same problem without success.
Have you now a solution concerning this problem of gaobal variables with require command ?
Does an include() fix the problem ?

Thank you in advance
HV
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 00:03:19 2022 UTC