php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5606 Number of arguments in function is required in full count.
Submitted: 2000-07-15 11:32 UTC Modified: 2000-07-22 11:32 UTC
From: mikro at nextra dot sk Assigned:
Status: Closed Package: Other
PHP Version: 4.0.1pl2 OS: MS Windows NT 4.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mikro at nextra dot sk
New email:
PHP Version: OS:

 

 [2000-07-15 11:32 UTC] mikro at nextra dot sk
I think this is bug, but I am not sure.

In PHP4 beta 2 when I make something like this:

function Foo($arg1,$arg2,$arg3){
   do some foo code
}

Foo(); // this is important

this was correct. But now I need to enter all arguments in function calling procedure - Foo(1,2,3). I think this is wrong. Why I must enter all arguments.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-14 20:55 UTC] sterling at cvs dot php dot net
Not a bug, correct behavior.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 11:05:53 2022 UTC