php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56050 build fails during pear install
Submitted: 2004-05-03 18:29 UTC Modified: 2004-05-03 20:23 UTC
From: omer at insan dot net Assigned: wez (profile)
Status: Closed Package: mailparse (PECL)
PHP Version: 4.3.4 OS: RedHat Fedora 1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: omer at insan dot net
New email:
PHP Version: OS:

 

 [2004-05-03 18:29 UTC] omer at insan dot net
Description:
------------
on php 4.3.4 with bcmath bz2, calendar, ctype, curl, dba, dbx, dio, exif, ftp, gd, gettext, gmp, iconv, imap, mbstring, mysql, ncurses, openssl, overload, pcre, posix, pspell, session,shmop, sockets, standard, sysvsem, sysvshm, tokenizer, wddx, xml, yp,zlib

during pear install mailparse  after successfull download and checks during make i get 

In file included from /tmp/tmpkXzKgs/mailparse-2.0b/mailparse.c:27:
/tmp/tmpkXzKgs/mailparse-2.0b/php_mailparse.h:86:49: ext/mbstring/libmbfl/mbfl/mbfilter.h: No such file or directory
In file included from /tmp/tmpkXzKgs/mailparse-2.0b/php_mailparse.h:95,
                 from /tmp/tmpkXzKgs/mailparse-2.0b/mailparse.c:27:
/tmp/tmpkXzKgs/mailparse-2.0b/php_mailparse_mime.h:68: error: syntax error before "mbfl_convert_filter"
/tmp/tmpkXzKgs/mailparse-2.0b/php_mailparse_mime.h:68: warning: no semicolon at end of struct or union
/tmp/tmpkXzKgs/mailparse-2.0b/php_mailparse_mime.h:82: error: syntax error before '}' token
/tmp/tmpkXzKgs/mailparse-2.0b/mailparse.c: In function `mimepart_dtor':
/tmp/tmpkXzKgs/mailparse-2.0b/mailparse.c:120: error: dereferencing pointer to incomplete type
/tmp/tmpkXzKgs/mailparse-2.0b/mailparse.c:120: error: dereferencing pointer to incomplete type
/tmp/tmpkXzKgs/mailparse-2.0b/mailparse.c:121: error: dereferencing pointer to incomplete type
/tmp/tmpkXzKgs/mailparse-2.0b/mailparse.c: In function `mailparse_mimemessage_export':
/tmp/tmpkXzKgs/mailparse-2.0b/mailparse.c:209: error: dereferencing pointer to incomplete type

and continue in similiar manner to

/tmp/tmpkXzKgs/mailparse-2.0b/mailparse.c:1523: error: dereferencing pointer to incomplete type
make: *** [mailparse.lo] Error 1
`make' failed

and exits.





Reproduce code:
---------------
pear install mailparse  executed as root.

Expected result:
----------------
im not sur what the successful exit is because i havent seen it yet ;)

Actual result:
--------------
more details in description section;

make: *** [mailparse.lo] Error 1
`make' failed


i do see a /usr/share/pear/doc/mailparse created without any content.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-03 18:59 UTC] omer at insan dot net
just fixing the php version from 4.3.3 which was the latest available in the pulldown menu of the bug-report add page.

same issue exists for pear downloaded and seld downloaded packages.
 [2004-05-03 20:23 UTC] wez@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php

Upgrade to a newer PHP version; mbstring in 4.3.4 was broken.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Oct 21 19:01:23 2020 UTC