php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56020 PATCH: manual navigation bar HTML tags not balanced
Submitted: 2004-03-31 15:23 UTC Modified: 2004-04-01 01:04 UTC
From: danielc at analysisandsolutions dot com Assigned: mj (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: danielc at analysisandsolutions dot com
New email:
PHP Version: OS:

 

 [2004-03-31 15:23 UTC] danielc at analysisandsolutions dot com
Description:
------------
There are imbalanced HTML tags in the top navigation bar of the manual.  This is caused by a boo-boo in the navigationBar() function in pearweb/include/pear-manual.php.

Here is a patch that both fixes this problem and tidys up the HTML output so one can clearly see what's going on when making future changes.

http://www.analysisandsolutions.com/pear/include.manual.balance.diff



Reproduce code:
---------------
Go to any manual page, such as
http://pear.php.net/manual/en/package.database.php

Look at the source of the language navigation bar.

Expected result:
----------------
... snip ...
  <td align="right">
   <small>Last updated: Sun, 28 Mar 2004</small>
  </td>
 </tr>
</table>


Actual result:
--------------
... snip ...
  <td align="right">
   <small>Last updated: Sun, 28 Mar 2004</small>
  </td>
 </tr>

</small></td></tr></table>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-01 01:04 UTC] mj@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pear.php.net.

In case this was a pear.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PEAR better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jan 17 04:01:23 2021 UTC