php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56006 enhancement: List of deps should include note if package is optional
Submitted: 2004-03-16 21:22 UTC Modified: 2004-03-17 02:08 UTC
From: pear dot neufeind at speedpartner dot de Assigned: mj (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pear dot neufeind at speedpartner dot de
New email:
PHP Version: OS:

 

 [2004-03-16 21:22 UTC] pear dot neufeind at speedpartner dot de
Description:
------------
It would be good if a list of dependencies for a package (on the website) could include a note if the dependencies are marked as "optional". Maybe just an "(optional)" at the end of the line.

Reproduce code:
---------------
any package with optional dependencies, e.g.:
http://pear.php.net/package/Structures_DataGrid


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-03-16 21:30 UTC] neufeind@php.net
Having a look at /public_html/package-info.php I found out this feature is already present. However the optional is possibly not displayed here because optional is set to "Yes" in the package.xml. Is case-sensitivity the problem here? If yes we should either do case-insensitive checks or enforce harder checks when uploading a release (reject "Yes" there already if it should be lower case).
 [2004-03-17 02:08 UTC] mj@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pear.php.net.

In case this was a pear.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PEAR better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jan 17 04:01:23 2021 UTC