php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55979 bz2 links send wrong Content-Type
Submitted: 2004-02-06 13:37 UTC Modified: 2004-02-07 16:30 UTC
From: php at cipri dot com Assigned: mj (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: Irrelevant OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php at cipri dot com
New email:
PHP Version: OS:

 

 [2004-02-06 13:37 UTC] php at cipri dot com
Description:
------------
Downloading the bz2 zipped version of the manual[1] sends a wrong HTTP header, which causes Internet Explorer to save the file as manual.tar.tar.
This is the wrong header that is send during this process is the.

Content-Type: application/x-tar

Ths .bz2 file is not a tar file at all, but a bz2 file :)

[1] http://pear.php.net/distributions/manual/pear_manual_en.tar.bz2


Reproduce code:
---------------
Download http://pear.php.net/distributions/manual/pear_manual_en.tar.bz2


Expected result:
----------------
Have IE save the file as pear_manual_en.tar.bz2

Actual result:
--------------
IE saves the file as pear_manual_en.tar.tar

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-07 16:30 UTC] mj@php.net
Looks like application/octet-stream is the correct content type. I've changed the server configuration accordingly.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jan 17 03:01:23 2021 UTC