php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55923 Error after final Bug Submit form
Submitted: 2003-11-27 14:19 UTC Modified: 2003-11-27 15:47 UTC
From: davey@php.net Assigned: mj (profile)
Status: Closed Package: PECL bug system (PECL)
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: davey@php.net
New email:
PHP Version: OS:

 

 [2003-11-27 14:19 UTC] davey@php.net
Description:
------------
When confirming a bug report, i.e. after writing it, click submit, it brings up some possible duplicate bugs, click submit again to finalize it, that page the form submits too yields the following error:

Warning: implode(): Bad arguments. in /usr/local/www/pearweb/public_html/bugs/include/functions.inc on line 497

Warning: Cannot modify header information - headers already sent by (output started at /usr/local/www/pearweb/public_html/bugs/include/functions.inc:497) in /usr/local/www/pearweb/public_html/bugs/report.php on line 188

Obviously I imagine the latter error is because of the former.

- Davey


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-27 14:20 UTC] davey@php.net
My original error report was this, I wonder if its content caused the error:

As discussed on PEAR-DEV, http://preview.pear.php.net/package-proposal-bbcode-help.php
needs to be fixed thus:

Latter bbcodes need to be removed or fixed. Personally I see no reason to put images in the proposals....

The titles, are currently "styled" using <span class="cattitle">TITLE</span>, these should be change to <h2>'s or other appropriate <h1>-<h6> tags.

- Davey
 [2003-11-27 14:47 UTC] mroch@php.net
It's not the content of the bug, it did it for me too.  Didn't see this one until just now, so marking my bug (316) as a duplicate of this.
 [2003-11-27 15:02 UTC] davey@php.net
Important to note that it did NOT do it for this bug itself...

so perhaps its to do with the category, or it MUST be the bug report contents...

- Davey
 [2003-11-27 15:15 UTC] php at cipri dot com
I checked the code via the CVS, and think I found the reason for this. See the diff created at http://cvs.php.net/diff.php/pearweb/public_html/bugs/include/functions.inc?login=2&f=&r1=0&tr1=1.8&ty=h&r2=0&tr2=1.9

Open http://cvs.php.net/co.php/pearweb/public_html/bugs/include/functions.inc?login=2&r=1.9 for the full source, scroll down and you'll find the error to be on an implode(", ", $to). If the package doesn't have any maintainers defined, which I guess PEPr wouldn't, $to will still be undefined and thus it'll crash. Best solutions would be to define $to as an array() beforehand, near the beginning of that function.
 [2003-11-27 15:47 UTC] mj@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pear.php.net.

In case this was a pear.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PEAR better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 04:01:24 2020 UTC