php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55809 PHP 5.3.5-1ubuntu7.2ppa1~natty
Submitted: 2011-09-28 20:31 UTC Modified: 2011-09-28 23:26 UTC
From: petr at bugyik dot cz Assigned:
Status: Not a bug Package: Strings related
PHP Version: 5.3SVN-2011-09-28 (SVN) OS: ubuntu
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: petr at bugyik dot cz
New email:
PHP Version: OS:

 

 [2011-09-28 20:31 UTC] petr at bugyik dot cz
Description:
------------
Creating an instance with string 
(http://www.php.net/manual/en/language.oop5.basic.php#language.oop5.basic.new) 
not accepted actual namespace.

Test script:
---------------
http://goo.gl/wh6U4

Expected result:
----------------
No error

Actual result:
--------------
[o5@sandy]$ php Foo.php 
PHP Fatal error:  Class 'Bar' not found in /home/o5/www/test/bug/Foo.php on line 
11
PHP Stack trace:
PHP   1. {main}() /home/o5/www/test/bug/Foo.php:0
PHP   2. Foo\Foo->__construct() /home/o5/www/test/bug/Foo.php:15

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-28 23:26 UTC] cataphract@php.net
-Status: Open +Status: Bogus
 [2011-09-28 23:26 UTC] cataphract@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

http://php.net/manual/en/language.namespaces.dynamic.php
 [2011-09-29 05:36 UTC] petr at bugyik dot cz
I thought it was a bug, because the creation of the classic instances using new 
Bar() works (without complete fully qualified name).
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Oct 28 03:01:23 2020 UTC