php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55796 directive mysql.connect_charset missing
Submitted: 2011-09-27 09:59 UTC Modified: 2011-10-18 13:03 UTC
Votes:3
Avg. Score:4.3 ± 0.9
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: b dot cropp at srz dot de Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.3.8 OS: gentoo linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: b dot cropp at srz dot de
New email:
PHP Version: OS:

 

 [2011-09-27 09:59 UTC] b dot cropp at srz dot de
Description:
------------
After updating from PHP-5.3.6 to 5.3.8 directive mysql.connect_charset seems to be missing.

Is this a bug or wanted? If it's wanted, how should I now handle the db communication? Please give me a reference for this new behaviour.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-10-12 10:21 UTC] git dot user at gmail dot com
seems like duplicate of https://bugs.php.net/bug.php?id=33604
 [2011-10-18 13:03 UTC] andrey@php.net
-Status: Open +Status: Bogus
 [2011-10-18 13:03 UTC] andrey@php.net
After some googling :
"In setting up this new server I discover to my surprise that the *.connect_charset directives are a Gentoo specific patch to PHP, and RHEL's version of PHP doesn't recognize them! Now how do I set PHP to connect to MySQL with the latin1 charset?"

http://serverfault.com/questions/97759/set-default-mysql-connect-charset-for-php-in-rhel
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 27 13:06:06 2022 UTC