|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55777 Error starting Apache server
Submitted: 2011-09-25 01:34 UTC Modified: 2015-05-28 12:40 UTC
Avg. Score:4.7 ± 0.7
Reproduced:18 of 18 (100.0%)
Same Version:11 (61.1%)
Same OS:9 (50.0%)
From: jlmueller at optonline dot net Assigned: cmb (profile)
Status: Not a bug Package: Apache2 related
PHP Version: 5.3.8 OS: win xp sp3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: jlmueller at optonline dot net
New email:
PHP Version: OS:


 [2011-09-25 01:34 UTC] jlmueller at optonline dot net
Just installed Apache 2.2.21 upgrade and PHP 5.3.8.
Had run earlier editions of both without problem.

We starting the Apache server it fails with the following error

Faulting application httpd.exe, version, faulting module php5ts.dll, version, fault address 0x000f8a90.

It is repeatable.

If I comment out the following PHP entries in the Apache hppd.config file entries
   PHPIniDir "C:\Program Files\PHP\"
   LoadModule php5_module "C:\Program Files\PHP\php5apache2_2.dll"
Apache will start and I can do non-PHP based pages


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2011-10-07 04:15 UTC] haryo at ukdw dot ac dot id
i've got same error with apache 2.2.21 and php 5.3.8 on windows 2008 server,
then i try to change '\' character with '/' and apache run smoothly 

here's my conf
PHPIniDir "C:/PHP/"
LoadFile "C:/PHP/php5ts.dll"
LoadModule php5_module "C:/PHP/php5apache2_2.dll"
php_value extension_dir "C:/PHP/ext/"

funny thing is: i have apache 2.2.19 which running okay with '\' char

..sorry for my english, it's not my first language
 [2011-10-08 01:20 UTC] jlmueller at optonline dot net
I tried haryo's suggested change of '/' instead of '\'.

I still get the same error message as before.
 [2011-10-20 01:04 UTC] jlmueller at optonline dot net
I tried going back to PHP 5.2.17 and now things work normally.
I guess there is problem with the 5.3.x version form my configuration
 [2011-12-08 16:26 UTC] justin dot mcdaniel at shipconstructor dot com
I was able to solve the issue by commenting out the PHP_SQLSRV extension. If you 
are not hooking up to an MSSQL database, please find the [PHP_SQLSRV] extension 
line and comment it out:



To this:

; extension=php_sqlsrv.dll

If you do need this extension, then you might want to try finding another 
version of the dll as the one included with PHP 5.3.8 appears to cause errors.
 [2015-05-28 12:40 UTC]
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2015-05-28 12:40 UTC]
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Quite likely the problem has been caused by a missing or
incompatible DLL. Recent downloads of PHP binaries contain
deplister.exe (otherwise you can get it from
<>), which can be used
to check the dependencies of a certain binary (PE module).
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 21:01:28 2024 UTC