|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55579 buildconf fails
Submitted: 2011-09-04 08:53 UTC Modified: 2011-09-04 17:21 UTC
From: Assigned:
Status: Wont fix Package: PHP-GTK related
PHP Version: 5.3.8 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
New email:
PHP Version: OS:


 [2011-09-04 08:53 UTC]
Running ./buildconf from a fresh svn checkout fails.

It's a Ubuntu 11.04 system with php 5.3.5

Actual result:
cweiske:~/Dev/> ./buildconf
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
rebuilding aclocal.m4
rebuilding configure warning: LTOPTIONS_VERSION is m4_require'd but not m4_defun'd
aclocal.m4:2950: LT_INIT is expanded from...
aclocal.m4:2985: AC_PROG_LIBTOOL is expanded from... the top level warning: LTSUGAR_VERSION is m4_require'd but not m4_defun'd warning: LTVERSION_VERSION is m4_require'd but not m4_defun'd warning: LTOBSOLETE_VERSION is m4_require'd but not m4_defun'd
configure:12127: error: possibly undefined macro: m4_ifval
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure:15154: error: possibly undefined macro: _LT_SET_OPTIONS
configure:15154: error: possibly undefined macro: LT_INIT
make[1]: *** [configure] Fehler 1
make: *** [all] Fehler 2


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-04 09:54 UTC]
Have you tried applying the patch[1] for the autoconf evil?

 [2011-09-04 16:07 UTC]
No, I did not try it.

Did it now and it worked! It should probably be applied to src.

This also makes bug #55580 work.
 [2011-09-04 17:21 UTC]
-Status: Open +Status: Wont fix
 [2011-09-04 17:21 UTC]
This is an issue with something that Ubuntu does to php build files -

If you build PHP from source instead of using Ubuntu's build, and then build php-gtk it works perfectly.  We CAN'T just apply the patch to the source proper because then it breaks the build on every other system and regular source builds.

If you're an automake guru and can find a way to fix the patch to work against Ubuntu's PHP build and not break a "virgin" php-gtk build or a build on other system's I'd love that - but so far no one has been able to figure out how to do that.
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 17 19:01:23 2020 UTC