php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #55513 Improve the appearance of the manual
Submitted: 2011-08-26 17:54 UTC Modified: 2011-08-27 23:58 UTC
From: anonymous at anonymous dot anonymous Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: anonymous at anonymous dot anonymous
New email:
PHP Version: OS:

 

 [2011-08-26 17:54 UTC] anonymous at anonymous dot anonymous
Description:
------------
In 2007 I downloaded the "Enhanced" user manual with the user notes. It's been a fantastic resource. I keep it on a hotkey.

This download disappeared from the website for a long time so I just kept using the 2007 version.

Today I noticed that it's back on the website. I've downloaded it, but I feel like its visual appearance has deteriorated.

Compare:
Old: http://i.imgur.com/ozinF.png
New: http://i.imgur.com/Am2XS.png

The old style works very well. It's colorful, clear to read and nicely laid out. You can get the most important function information at a glance. It's not perfect; there are some ways its presentation could be improved, but nothing to get upset about.

The new style -- well, maybe I need time to get used to it, but it seems drab by comparison, it doesn't flow as well visually, and most of all it takes up too much screen space for the same content. (That's even though in the screenshot of the new version, I've already reduced the font size from the default.)

I think some thoughtful visual optimization of the manual could do wonders to make it more pleasant and more efficient.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-08-27 23:58 UTC] rquadling@php.net
-Status: Open +Status: Bogus
 [2011-08-27 23:58 UTC] rquadling@php.net
The current CHM file is based upon the same layout as the live documentation. Same HTML layout and CSS styling.

The PHP website is currently undergoing a restyling. You can see this at http://www.php.net?beta=1

Behind the scenes, the CHM files (with and without usernotes) are being developed to include the new styling, but these aren't for public consumption just yet. Mainly because the site styling is subject to change.

As things stand, there are no plans to introduce additional styling for either the PHP websites or the CHM files.

I recently had to shelve a feature to allow third party, external CSS files for the CHM files. There is a limitation on where the CSS files can reside which I felt would be unpopular with users.

If you want more details than this, please contact me directly (RQuadling @ php.net).
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Apr 02 23:01:23 2020 UTC