php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55437 mongodb driver problem, cannot insert, cause segfault
Submitted: 2011-08-17 01:53 UTC Modified: 2011-08-17 03:17 UTC
From: rubing dot duan at gmail dot com Assigned:
Status: Not a bug Package: *Math Functions
PHP Version: 5.3SVN-2011-08-17 (SVN) OS: ubuntu
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: rubing dot duan at gmail dot com
New email:
PHP Version: OS:

 

 [2011-08-17 01:53 UTC] rubing dot duan at gmail dot com
Description:
------------
the latest version of mongodb driver (1.2.3) does not support insert.

.........
$collection->insert(array('user' => $username, 'pwd' => md5($username . ":mongo:" . $password) , 'readOnly' => $readOnly), array('safe' => true));
.........

I got this output:

..Segmentation fault

After I reinstalled mongodb driver (1.1.4), the problem was solved.

Test script:
---------------
.........
$collection = $this->mongo->selectDB($databaseName)->selectCollection("system.users");

$collection->insert(array('user' => $username, 'pwd' => md5($username . ":mongo:" . $password) , 'readOnly' => $readOnly), array('safe' => true));
.........

Expected result:
----------------
can run 

Actual result:
--------------
..Segmentation fault

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-08-17 03:17 UTC] laruence@php.net
-Status: Open +Status: Bogus -Package: *General Issues +Package: *Math Functions
 [2011-08-17 03:17 UTC] laruence@php.net
Please report this bug to the mongodb packageon pecl.php.net(http://pecl.php.net/package/mongo)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Mar 04 13:01:25 2021 UTC