php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #554 empty POST to any .php3 script causes apache to seg fault.
Submitted: 1998-07-15 11:25 UTC Modified: 1998-07-15 11:28 UTC
From: musone at afterfive dot com Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 3.0 Final Release OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: musone at afterfive dot com
New email:
PHP Version: OS:

 

 [1998-07-15 11:25 UTC] musone at afterfive dot com
a simple POST through telnet not containing anything
seems to crash apache.

heres an example:

>telnet elmwood.afterfive.com 80
Connected to elmwood.afterfive.com

POST /~musone/index.php3 HTTP/1.0

(note two cr's, ending my post)


Connection closed by foreign host

The error_log file contains:
httpd: chile pid 9947 exit signal Segmentation Fault (11)

This was also reproduced on the php web site:

telnet www.php.net 80
POST /docs.php3 HTTP/1.0

Connection closed by foreign host.

NOTE: this was originaly found because i have ie3.0 sending some bad or incomplete post data, which i'm looking into more, so it might not be as simple as an "empty" post.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-07-15 11:28 UTC] rasmus
Yup.  Known bug and already fixed in CVS.  Will be part of 3.0.2 this weekend.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jun 17 00:01:28 2019 UTC