php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55330 utf8_encode CRASH when $data is a very big string
Submitted: 2011-07-31 21:37 UTC Modified: 2011-08-01 15:05 UTC
From: bruno dot boccara at d2b dot com Assigned:
Status: Closed Package: Recode related
PHP Version: 5.3.6 OS: WINDOWS 2008 R2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bruno dot boccara at d2b dot com
New email:
PHP Version: OS:

 

 [2011-07-31 21:37 UTC] bruno dot boccara at d2b dot com
Description:
------------
Hello,
the http server is apache 2.2.17

I used for years the function utf8_encode to encode a file into this code.
The file is text string that I write into a file.
I remarked that if this file is more than a value thath I still not identified, but a very big size (in my test it was a 70MB file), the script crash and nothing is returned.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-07-31 21:51 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2011-07-31 21:51 UTC] pajoye@php.net
Are you sure you are not reaching the memory limit? What says the log (or set 
display_errors to on)
 [2011-08-01 15:05 UTC] bruno dot boccara at d2b dot com
-Status: Feedback +Status: Closed
 [2011-08-01 15:05 UTC] bruno dot boccara at d2b dot com
Very sorry you're right.
greater memory_size resolve the problem.
this is not a bug.

Regards.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 26 13:01:25 2019 UTC