php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55251 coredumped when startup php-fpm
Submitted: 2011-07-20 09:00 UTC Modified: 2011-07-20 09:57 UTC
From: paulgao at yeah dot net Assigned: fat (profile)
Status: Not a bug Package: FPM related
PHP Version: 5.4SVN-2011-07-20 (SVN) OS: Centos 6 64-bit
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: paulgao at yeah dot net
New email:
PHP Version: OS:

 

 [2011-07-20 09:00 UTC] paulgao at yeah dot net
Description:
------------
core dumped.

Test script:
---------------
/usr/local/php/sbin/php-fpm --fpm-config /home/codebase/server-config/php-fpm-www-test.ini

Expected result:
----------------
(gdb) bt
#0  0x00007f2587c469a5 in raise () from /lib64/libc.so.6
#1  0x00007f2587c48185 in abort () from /lib64/libc.so.6
#2  0x00007f2587c83d5b in __libc_message () from /lib64/libc.so.6
#3  0x00007f2587c89676 in malloc_printerr () from /lib64/libc.so.6
#4  0x00000000006bc0bd in destroy_zend_class (pce=<value optimized out>) at /root/php-5.4.0alpha2/Zend/zend_opcode.c:331
#5  0x00000000006d09d3 in zend_hash_clean (ht=0x2ea0c90) at /root/php-5.4.0alpha2/Zend/zend_hash.c:596
#6  0x00000000004a17fc in apc_interned_strings_shutdown () at /root/php-5.4.0alpha2/ext/apc/apc_string.c:226
#7  0x000000000049a1f9 in apc_module_shutdown () at /root/php-5.4.0alpha2/ext/apc/apc_main.c:895
#8  0x0000000000491097 in zm_shutdown_apc (type=<value optimized out>, module_number=6) at /root/php-5.4.0alpha2/ext/apc/php_apc.c:373
#9  0x00000000006c9b45 in module_destructor (module=0x2ebc180) at /root/php-5.4.0alpha2/Zend/zend_API.c:2248
#10 0x00000000006d03eb in zend_hash_apply_deleter (ht=0xee7e40, p=0x2ebc120) at /root/php-5.4.0alpha2/Zend/zend_hash.c:650
#11 0x00000000006d0688 in zend_hash_graceful_reverse_destroy (ht=0xee7e40) at /root/php-5.4.0alpha2/Zend/zend_hash.c:687
#12 0x00000000006c4898 in zend_shutdown () at /root/php-5.4.0alpha2/Zend/zend.c:806
#13 0x000000000066b92a in php_module_shutdown () at /root/php-5.4.0alpha2/main/main.c:2264
#14 0x0000000000770939 in fpm_php_cleanup (which=<value optimized out>, arg=<value optimized out>) at /root/php-5.4.0alpha2/sapi/fpm/fpm/fpm_php.c:199
#15 0x00000000007691be in fpm_cleanups_run (type=2) at /root/php-5.4.0alpha2/sapi/fpm/fpm/fpm_cleanup.c:45
#16 0x0000000000775bca in fpm_unix_init_main () at /root/php-5.4.0alpha2/sapi/fpm/fpm/fpm_unix.c:252
#17 0x0000000000768695 in fpm_init (argc=<value optimized out>, argv=<value optimized out>, config=<value optimized out>, prefix=<value optimized out>, pid=<value optimized out>, test_conf=0)
    at /root/php-5.4.0alpha2/sapi/fpm/fpm/fpm.c:55
#18 0x000000000076f24a in main (argc=3, argv=0x7fff72a97458) at /root/php-5.4.0alpha2/sapi/fpm/fpm/fpm_main.c:1731
(gdb) 

Actual result:
--------------
startup OK.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-07-20 09:02 UTC] paulgao at yeah dot net
[root@centos tmp]# /usr/local/php/sbin/php-fpm --fpm-config /home/codebase/server-config/php-fpm-www-test.ini -tt
[20-Jul-2011 21:01:43] NOTICE: [General]
[20-Jul-2011 21:01:43] NOTICE:  pid = /home/php-fpm.pid
[20-Jul-2011 21:01:43] NOTICE:  error_log = /home/logs/fpm.log
[20-Jul-2011 21:01:43] NOTICE:  syslog.ident = php-fpm
[20-Jul-2011 21:01:43] NOTICE:  syslog.facility = 24
[20-Jul-2011 21:01:43] NOTICE:  log_level = NOTICE
[20-Jul-2011 21:01:43] NOTICE:  emergency_restart_interval = 60s
[20-Jul-2011 21:01:43] NOTICE:  emergency_restart_threshold = 10
[20-Jul-2011 21:01:43] NOTICE:  process_control_timeout = 5s
[20-Jul-2011 21:01:43] NOTICE:  process.max = 0
[20-Jul-2011 21:01:43] NOTICE:  daemonize = yes
[20-Jul-2011 21:01:43] NOTICE:  rlimit_files = 0
[20-Jul-2011 21:01:43] NOTICE:  rlimit_core = 0
[20-Jul-2011 21:01:43] NOTICE:  
[20-Jul-2011 21:01:43] NOTICE: [www-test]
[20-Jul-2011 21:01:43] NOTICE:  prefix = undefined
[20-Jul-2011 21:01:43] NOTICE:  user = nobody
[20-Jul-2011 21:01:43] NOTICE:  group = nobody
[20-Jul-2011 21:01:43] NOTICE:  listen = /tmp/php-cgi.socket
[20-Jul-2011 21:01:43] NOTICE:  listen.backlog = -1
[20-Jul-2011 21:01:43] NOTICE:  listen.owner = undefined
[20-Jul-2011 21:01:43] NOTICE:  listen.group = undefined
[20-Jul-2011 21:01:43] NOTICE:  listen.mode = 0666
[20-Jul-2011 21:01:43] NOTICE:  listen.allowed_clients = undefined
[20-Jul-2011 21:01:43] NOTICE:  pm = dynamic
[20-Jul-2011 21:01:43] NOTICE:  pm.max_children = 192
[20-Jul-2011 21:01:43] NOTICE:  pm.start_servers = 16
[20-Jul-2011 21:01:43] NOTICE:  pm.min_spare_servers = 8
[20-Jul-2011 21:01:43] NOTICE:  pm.max_spare_servers = 32
[20-Jul-2011 21:01:43] NOTICE:  pm.max_requests = 0
[20-Jul-2011 21:01:43] NOTICE:  pm.status_path = /fpm_status
[20-Jul-2011 21:01:43] NOTICE:  ping.path = /fpm_ping
[20-Jul-2011 21:01:43] NOTICE:  ping.response = pong
[20-Jul-2011 21:01:43] NOTICE:  access.log = undefined
[20-Jul-2011 21:01:43] NOTICE:  access.format = undefined
[20-Jul-2011 21:01:43] NOTICE:  slowlog = /home/logs/fpm_slow.log
[20-Jul-2011 21:01:43] NOTICE:  request_slowlog_timeout = 1s
[20-Jul-2011 21:01:43] NOTICE:  request_terminate_timeout = 0s
[20-Jul-2011 21:01:43] NOTICE:  rlimit_files = 51200
[20-Jul-2011 21:01:43] NOTICE:  rlimit_core = 0
[20-Jul-2011 21:01:43] NOTICE:  chroot = 
[20-Jul-2011 21:01:43] NOTICE:  chdir = 
[20-Jul-2011 21:01:43] NOTICE:  catch_workers_output = yes
[20-Jul-2011 21:01:43] NOTICE:  security.limit_extensions = .php
[20-Jul-2011 21:01:43] NOTICE:  
[20-Jul-2011 21:01:43] NOTICE: configuration file /home/codebase/server-config/php-fpm-www-test.ini test is successful
 [2011-07-20 09:17 UTC] fat@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: fat
 [2011-07-20 09:24 UTC] fat@php.net
-Status: Assigned +Status: Feedback
 [2011-07-20 09:24 UTC] fat@php.net
it seems to be related to APC not to FPM directly:

#6  0x00000000004a17fc in apc_interned_strings_shutdown () at /root/php-
5.4.0alpha2/ext/apc/apc_string.c:226
#7  0x000000000049a1f9 in apc_module_shutdown () at /root/php-
5.4.0alpha2/ext/apc/apc_main.c:895

Can you please desactivate APC and confirm the bug's gone ?
 [2011-07-20 09:37 UTC] paulgao at yeah dot net
yes, you are right, APC is bad...
 [2011-07-20 09:57 UTC] fat@php.net
-Status: Feedback +Status: Bogus
 [2011-07-20 09:57 UTC] fat@php.net
please open a bug report to http://pecl.php.net/bugs/report.php?package=APC

i'm closing this one

++ jerome
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC