php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55125 Missing parser error
Submitted: 2011-07-04 03:07 UTC Modified: 2011-07-04 06:33 UTC
From: info at nevalon dot de Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 5.3.6 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: info at nevalon dot de
New email:
PHP Version: OS:

 

 [2011-07-04 03:07 UTC] info at nevalon dot de
Description:
------------
Line 3 is incorrect and should trigger an parser error but it doesn't if in the next line there is a var_dump.

Test script:
---------------
<?php

$message = '';
$message =
var_dump($message);

Expected result:
----------------
Parser error

Actual result:
--------------
Nothing

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-07-04 06:33 UTC] cataphract@php.net
-Status: Open +Status: Bogus
 [2011-07-04 06:33 UTC] cataphract@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Apr 06 12:01:25 2020 UTC