php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #55079 parameter raw_output describe problem in md5 function
Submitted: 2011-06-30 01:20 UTC Modified: 2011-07-12 02:39 UTC
From: imanecr at gmail dot com Assigned:
Status: Duplicate Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: imanecr at gmail dot com
New email:
PHP Version: OS:

 

 [2011-06-30 01:20 UTC] imanecr at gmail dot com
Description:
------------
from http://cn.php.net/manual/en/function.md5.php
raw_output:
If the optional raw_output is set to TRUE, then the md5 digest is instead returned 
in raw binary format with a length of 16.
It is confusing.
The raw binary format should be writen 16 bytes.
For the Chinese translation, "a length of 16" has been translated into 16 bits. it 
should be bytes.

The original sentence(Chinese translation):
那么 MD5 报文摘要将以原始的 16 位二进制格式返回。


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-06-30 01:32 UTC] imanecr at gmail dot com
relate to
 https://bugs.php.net/bug.php?id=55054
 [2011-07-12 02:39 UTC] yannick@php.net
-Status: Open +Status: Duplicate
 [2011-07-12 02:39 UTC] yannick@php.net
Duplicate of bug #55054
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 19 21:01:24 2020 UTC