php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55037 php_zval_filter_recursive segfault
Submitted: 2011-06-12 03:18 UTC Modified: 2013-02-18 00:34 UTC
From: crrodriguez at opensuse dot org Assigned:
Status: No Feedback Package: Filter related
PHP Version: 5.3SVN-2011-06-12 (SVN) OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: crrodriguez at opensuse dot org
New email:
PHP Version: OS:

 

 [2011-06-12 03:18 UTC] crrodriguez at opensuse dot org
Description:
------------
Hi:

php_zval_filter_recursive segfaults once in a while, with the following backtrace



Test script:
---------------
Program terminated with signal 11, Segmentation fault.
#0  0x00007fb81e3a58a2 in php_zval_filter_recursive (value=0x7fb823d86768, filter=140736822777868, flags=140736822777848, options=0x7fb823d86790, copy=<value optimized out>, charset=0x0)
    at /usr/src/debug/php-5.3.6.201106102115/ext/filter/filter.c:524
529                             if (Z_TYPE_PP(element) == IS_ARRAY) {


(gdb) bt full
#0  0x00007fb81e3a58a2 in php_zval_filter_recursive (value=0x7fb823d86768, filter=140736822777868, flags=140736822777848, options=0x7fb823d86790, copy=<value optimized out>, charset=0x0)
    at /usr/src/debug/php-5.3.6.201106102115/ext/filter/filter.c:524
        element = 0x0
        pos = 0x7fb823d86790
#1  0x0000000000000000 in ?? ()

Im not familiar with the code so Im not sure if checking element != NULL is a correct fix.,

Expected result:
----------------
-----------

Actual result:
--------------
------------------------------

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-06-12 03:31 UTC] felipe@php.net
-Status: Open +Status: Feedback
 [2011-06-12 03:31 UTC] felipe@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc. If the script requires a 
database to demonstrate the issue, please make sure it creates 
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.


 [2013-02-18 00:34 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Apr 25 01:01:30 2024 UTC