php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54782 Missing default value for optional parameter in sqlite_unbuffered_query
Submitted: 2011-05-17 11:29 UTC Modified: 2011-05-18 01:17 UTC
From: gwarnants at gmail dot com Assigned: salathe (profile)
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Password:
Status:
Package:
Bug Type:
Summary:
From: gwarnants at gmail dot com
New email:
PHP Version: OS:

 

 [2011-05-17 11:29 UTC] gwarnants at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.sqlite-unbuffered-query#Description
---

According to parameters description, it seems default value for $result_type is missing in each function prototypes (procedural and oop).
The parameter should be assigned to constant SQLITE_BOTH

Regards,
Geoffray

Expected result:
----------------
resource sqlite_unbuffered_query ( resource $dbhandle , string $query [, int $result_type = SQLITE_BOTH [, string &$error_msg ]] )
resource sqlite_unbuffered_query ( string $query , resource $dbhandle [, int $result_type = SQLITE_BOTH [, string &$error_msg ]] )
SQLiteUnbuffered SQLiteDatabase::unbufferedQuery ( string $query [, int $result_type = SQLITE_BOTH [, string &$error_msg ]] )

Actual result:
--------------
resource sqlite_unbuffered_query ( resource $dbhandle , string $query [, int $result_type [, string &$error_msg ]] )
resource sqlite_unbuffered_query ( string $query , resource $dbhandle [, int $result_type [, string &$error_msg ]] )
SQLiteUnbuffered SQLiteDatabase::unbufferedQuery ( string $query [, int $result_type [, string &$error_msg ]] )

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-05-18 01:09 UTC] salathe@php.net
Automatic comment from SVN on behalf of salathe
Revision: http://svn.php.net/viewvc/?view=revision&revision=311167
Log: sqlite_*query() initializers (doc #54779 #54781 #54782)
 [2011-05-18 01:17 UTC] salathe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: salathe
 [2011-05-18 01:17 UTC] salathe@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC