php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54775 Bad variable argument list in register_tick_function
Submitted: 2011-05-17 11:05 UTC Modified: 2011-05-18 00:25 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: gwarnants at gmail dot com Assigned: salathe (profile)
Status: Wont fix Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: gwarnants at gmail dot com
New email:
PHP Version: OS:

 

 [2011-05-17 11:05 UTC] gwarnants at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.register-tick-function#Description
---

I think variable argument list of register_tick_function() function could be
rewritten in a more conveniant way, like any other similar function does (ie:
array_map).
Duplicating an optional parameter and "..." should be avoided because it
is
a redondant information.

Regards,
Geoffray

Expected result:
----------------
bool register_tick_function ( callback $function [, mixed $... ] )

Actual result:
--------------
bool register_tick_function ( callback $function [, mixed $arg [, mixed $... ]] )

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-05-18 00:25 UTC] salathe@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: salathe
 [2011-05-18 00:25 UTC] salathe@php.net
The current prototype makes it clear that the $... means more $arg's.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 00:01:29 2024 UTC