|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54752 Missing default value in pg_result_status prototype
Submitted: 2011-05-16 17:30 UTC Modified: 2011-05-16 17:45 UTC
From: gwarnants at gmail dot com Assigned: dtajchreber (profile)
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
38 - 27 = ?
Subscribe to this entry?

 [2011-05-16 17:30 UTC] gwarnants at gmail dot com
From manual page:

Default value for parameter $type should be defined using PGSQL_STATUS_LONG constant in the prototype according the description "If not specified, PGSQL_STATUS_LONG is the default."

Expected result:
mixed pg_result_status ( resource $result [, int $type = PGSQL_STATUS_LONG ] )

Actual result:
mixed pg_result_status ( resource $result [, int $type ] )


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2011-05-16 17:44 UTC]
Automatic comment from SVN on behalf of dtajchreber
Log: Doc Bug #54752 - Missing default value in pg_result_status prototype - added default value for type in signature
 [2011-05-16 17:45 UTC]
-Status: Open +Status: Closed -Assigned To: +Assigned To: dtajchreber
 [2011-05-16 17:45 UTC]
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC