php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54725 --
Submitted: 2011-05-13 07:45 UTC Modified: 2011-05-13 09:50 UTC
From: toms dot jel at seznam dot cz Assigned:
Status: Not a bug Package: Doc Build problem
PHP Version: 5.3.6 OS: Win 7
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: toms dot jel at seznam dot cz
New email:
PHP Version: OS:

 

 [2011-05-13 07:45 UTC] toms dot jel at seznam dot cz
Description:
------------
Parse error: syntax error, unexpected T_STRING, expecting T_VARIABLE or '$' in 
C:\web\prog\xampp\htdocs\web\discusion.php on line 8
This example from your manual, function getenv()

Test script:
---------------
$ip = $ _SERVER [ 'REMOTE_ADDR' ];

Expected result:
----------------
IP adress

Actual result:
--------------
Parse error: syntax error, unexpected T_STRING, expecting T_VARIABLE or '$' in 
C:\web\prog\xampp\htdocs\web\discusion.php on line 8

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-05-13 09:50 UTC] rasmus@php.net
-Status: Open +Status: Bogus
 [2011-05-13 09:50 UTC] rasmus@php.net
It is $_SERVER not $ _SERVER
 [2011-05-13 12:25 UTC] spam-free at blueyonder dot co dot uk
You have a space after the $, which the example does not.
 [2011-05-13 12:40 UTC] toms dot jel at seznam dot cz
I'm too sorry, I'm using google translator, because I don't understand to proffesional tittles. And if I'll translate it, the code looks differently like without translating.
And I'm starting with PHP.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 05:01:23 2020 UTC