php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #547 After executing msql access, php hangs
Submitted: 1998-07-13 08:05 UTC Modified: 1998-08-13 16:23 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: jpcivade at cge dot net Assigned:
Status: Closed Package: mSQL related
PHP Version: 3.0.1 OS: WIN98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jpcivade at cge dot net
New email:
PHP Version: OS:

 

 [1998-07-13 08:05 UTC] jpcivade at cge dot net
I've writtent a short program to test msql2.0 and PHP3.01 before starting my developpement..

Here's the source
<?
dl ("msql2.dll");
$result=msql ("docnetia", "select i_numero,c_intitule from t_documents where i_numero<5 order by i_numero"); 
$num = msql_numrows($result);
$i=0;
while($i<$num)
  {
  echo msql_result($result,$i,"i_numero");
  echo ": ";
  echo msql_result($result,$i,"c_intitule");
  echo "<br>\n";
  $i++;
  }
exit;
?>

After executing this script from a command.com, php hangs with a GPF. 
Notice the output seems to be OK, evry data request is effectively processed.
I seems to hang  just after execution, somewhere in the "quit code".
I've tried it with a static load of msq2.dll and with a dynamic load in my source code.
If somebody has got any idea, please mail me back at jpcivade@cge.net

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-08-13 16:23 UTC] shane
Until Hughes has an official port msql is experimental and unsupported.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 12:03:36 2021 UTC