php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54554 [ZH] translation of some CURLOPT in simplifed chinese is wrong.
Submitted: 2011-04-18 03:19 UTC Modified: 2012-10-27 16:35 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: xiezhenye at gmail dot com Assigned: daijie (profile)
Status: Closed Package: Translation problem
PHP Version: 5.3.6 OS: any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
46 + 48 = ?
Subscribe to this entry?

 
 [2011-04-18 03:19 UTC] xiezhenye at gmail dot com
Description:
------------
translation of curl_setopt CURLOPT_READFUNCTION description in simplifed chinese 
is wrong.

in english:
The name of a callback function where the callback function takes three 
parameters. The first is the cURL resource, the second is a stream resource 
provided to cURL through the option CURLOPT_INFILE, and the third is the maximum 
amount of data to be read. The callback function must return a string with a 
length equal or smaller than the amount of data requested, typically by reading 
it from the passed stream resource. It should return an empty string to signal 
EOF.

the correct chinese translation should be:
回调函数名。该函数应接受三个参数。第一个是 cURL resource;第二个是通过选项 
CURLOPT_INFILE 传给 cURL 的 stream resource;第三个参数是最大可以读取的数据的数量。回
调函数必须返回一个字符串,长度小于或等于请求的数据量(第三个参数)。一般从传入的 stream 
resource 读取。返回空字符串作为 EOF(文件结束) 信号。


Test script:
---------------
none


Expected result:
----------------
none

Actual result:
--------------
none

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-04-18 03:29 UTC] xiezhenye at gmail dot com
-Summary: translation of CURLOPT_READFUNCTION description in simplifed chinese is wrong. +Summary: translation of some CURLOPT in simplifed chinese is wrong.
 [2011-04-18 03:29 UTC] xiezhenye at gmail dot com
translation of curl_setopt CURLOPT_WRITEFUNCTION description in simplifed 
chinese 
is wrong.

in english:
The name of a callback function where the callback function takes two 
parameters. The first is the cURL resource, and the second is a string with the 
data to be written. The data must be saved by using this callback function. It 
must return the exact number of bytes written or the transfer will be aborted 
with an error.

the correct chinese translation should be:
回调函数名。该函数应接受两个参数。第一个是 cURL resource;第二个是要写入的数据字符串。数
据必须在函数中被保存。函数必须返回准确的传入的要写入数据的字节数,否则传输会被一个错误所中
断。
 [2011-05-09 22:42 UTC] yannick@php.net
-Summary: translation of some CURLOPT in simplifed chinese is wrong. +Summary: [ZH] translation of some CURLOPT in simplifed chinese is wrong.
 [2012-10-27 16:04 UTC] reeze@php.net
-Assigned To: +Assigned To: daijie
 [2012-10-27 16:04 UTC] reeze@php.net
@daijie 帮fix一下?
 [2012-10-27 16:21 UTC] daijie@php.net
Automatic comment from SVN on behalf of daijie
Revision: http://svn.php.net/viewvc/?view=revision&revision=328159
Log: Fix Doc Bug #54554,provide by xiezhenye at gmail dot com.
 [2012-10-27 16:33 UTC] daijie@php.net
Automatic comment from SVN on behalf of daijie
Revision: http://svn.php.net/viewvc/?view=revision&revision=328160
Log: Fix Doc Bug #54554(write function),provide by xiezhenye at gmail dot com.
 [2012-10-27 16:35 UTC] daijie@php.net
-Status: Assigned +Status: Closed
 [2012-10-27 16:35 UTC] daijie@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

Thanks,the correct Chinese translation has been committed to svn.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jul 13 22:01:29 2024 UTC