php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54522 400 Bad Request after login on wiki.php.net
Submitted: 2011-04-13 15:29 UTC Modified: 2011-04-15 12:20 UTC
From: tyra3l at gmail dot com Assigned: bjori (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: tyra3l at gmail dot com
New email:
PHP Version: OS:

 

 [2011-04-13 15:29 UTC] tyra3l at gmail dot com
Description:
------------
I've just tried to login to https://wiki.php.net/ for the first time since it got 
back online, and after I submitted the login form, I've got redirected to the 
following url:
http://wiki.php.net:443/start

which obviously gave me an:

400 Bad Request

The plain HTTP request was sent to HTTPS port
nginx

I suspect that there is a redirect in the wiki code which only sets the port for 
the url, not the schema.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-04-15 11:23 UTC] bjori@php.net
-Status: Open +Status: Verified
 [2011-04-15 11:23 UTC] bjori@php.net
Interesting. Verified with my username too.
 [2011-04-15 12:20 UTC] bjori@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: bjori
 [2011-04-15 12:20 UTC] bjori@php.net
Bleh. nginx doesn't expose $_SERVER["HTTPS"], which therefore made dokuwiki think 
this was http on 443 in the redirect.

This is fixed now, thanks for the report.
 [2011-04-15 12:26 UTC] tyra3l at gmail dot com
you are welcome, and thanks for the prompt fix. :)
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Apr 17 09:01:41 2024 UTC