php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54468 [FR] Translation to a wrong sense
Submitted: 2011-04-05 11:37 UTC Modified: 2011-04-06 23:08 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: olivier dot cecillon at gmail dot com Assigned: yannick (profile)
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: olivier dot cecillon at gmail dot com
New email:
PHP Version: OS:

 

 [2011-04-05 11:37 UTC] olivier dot cecillon at gmail dot com
Description:
------------
English version of str_replace for argument count says :
"If passed, this will be set to the number of replacements performed."

The french translation says :
"Si fourni, définira le nombre de remplacements à effectuer."

The french translation lets user suppose that count is a limit on the number of replacements the user wants the function to make, whereas it is expected to be a variable which will be passed by reference and be filled with the number of replacements the function will actually have made.

A correct translation would be :

"Une variable passée par référence. Si fournie, contiendra le nombre de remplacements effectués"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-04-06 22:44 UTC] yannick@php.net
-Summary: Translation to a wrong sense +Summary: [FR] Translation to a wrong sense
 [2011-04-06 23:08 UTC] yannick@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: yannick
 [2011-04-06 23:08 UTC] yannick@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

This bug have been solved last month in SVN. The current online documentation haven't been uptodate for some strange reason...
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 06:05:43 2022 UTC