php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54462 'echo $e->getTrace()' hangs
Submitted: 2011-04-04 04:06 UTC Modified: 2011-06-12 00:24 UTC
From: softwarevamp at gmail dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.2.17 OS: Window Xp Japanese
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: softwarevamp at gmail dot com
New email:
PHP Version: OS:

 

 [2011-04-04 04:06 UTC] softwarevamp at gmail dot com
Description:
------------
try to print out exception stacktrace, php hangs.

Test script:
---------------
try {
   throw new ErrorException("test");
} catch(Exception $e) {
    echo $e; //hangs here
}
i am using WINDOWS XP JAPANESE

Expected result:
----------------
print out the stack trace

Actual result:
--------------
hangs

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-06-10 03:38 UTC] dsp@php.net
-Status: Open +Status: Feedback
 [2011-06-10 03:38 UTC] dsp@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.

cannot reproduce it. please provide a stack trace where it's hanging.
 [2011-06-10 03:53 UTC] softwarevamp at gmail dot com
-Status: Feedback +Status: Open
 [2011-06-10 03:53 UTC] softwarevamp at gmail dot com
seems this only occurs in debug mode.
i am using ZendDebugger.dll 5.2.x
 [2011-06-12 00:24 UTC] felipe@php.net
-Status: Open +Status: Bogus
 [2011-06-12 00:24 UTC] felipe@php.net
Only with ZendDebugger? So not an issue in PHP itself.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 20 18:05:43 2022 UTC