php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54447 Imagick::getImageChannelMean Documentation is not correct
Submitted: 2011-04-01 21:07 UTC Modified: 2021-03-16 13:32 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: mark at intuitiveengineering dot com Assigned: cmb (profile)
Status: Closed Package: imagick (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mark at intuitiveengineering dot com
New email:
PHP Version: OS:

 

 [2011-04-01 21:07 UTC] mark at intuitiveengineering dot com
Description:
------------
---
From manual page: http://www.php.net/function.imagick-getimagechannelmean#Return Values
---

The return value of this function is an array with 2 values:

mean
standardDeviation

It does not simply return true on success.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-04-06 23:05 UTC] yannick@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: yannick
 [2011-04-06 23:05 UTC] yannick@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 [2011-04-06 23:06 UTC] yannick@php.net
-Status: Closed +Status: Re-Opened -Assigned To: yannick +Assigned To:
 [2011-04-06 23:06 UTC] yannick@php.net
Sorry, it's just an error.
Re-open it.
 [2015-05-08 17:39 UTC] cmb@php.net
-Status: Re-Opened +Status: Verified
 [2015-06-16 19:45 UTC] danack@php.net
-Assigned To: +Assigned To: danack
 [2017-01-28 11:28 UTC] cmb@php.net
-Package: Documentation problem +Package: imagick
 [2017-10-24 05:25 UTC] kalle@php.net
-Status: Verified +Status: Assigned
 [2017-10-24 09:44 UTC] danack@php.net
-Status: Assigned +Status: Verified
 [2017-10-24 09:44 UTC] danack@php.net
Unassigning - anyone can work on documentation.
 [2017-10-24 09:45 UTC] danack@php.net
-Assigned To: danack +Assigned To:
 [2021-01-09 16:34 UTC] afilina at gmail dot com
The manual page linked in the bug report no longer exists.
The one that does exist for getimagechannelmean (https://www.php.net/manual/en/imagick.getimagechannelmean) has the correct description of the return value:

===
Returns an array with "mean" and "standardDeviation" members.
===

I think that this issue can be closed.
 [2021-03-16 13:32 UTC] cmb@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: cmb
 [2021-03-16 13:32 UTC] cmb@php.net
Indeed, this has been fixed in the meantime.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Apr 22 14:01:24 2021 UTC