php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54425 Loading PHP extension fails due to incorrrect ini directory path
Submitted: 2011-03-30 17:28 UTC Modified: 2015-06-09 18:46 UTC
Votes:4
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: egil at wp dot pl Assigned: cmb (profile)
Status: Wont fix Package: Windows Installer
PHP Version: 5.3.6 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: egil at wp dot pl
New email:
PHP Version: OS:

 

 [2011-03-30 17:28 UTC] egil at wp dot pl
Description:
------------
Steps:
1. Install Apache (used 2.2.17 from Apache Lounge, but shouldn't be specific).
2. Install PHP 5.3.6 TS VC9 as Apache 2.2 module.

Expected result:
----------------
Expected result:
PHPIniDir "C:/Program Files/PHP/"
LoadModule php5_module "C:/Program Files/PHP/php5apache2_2.dll"

Actual result:
--------------
PHPIniDir "C:\Program Files\PHP\"
LoadModule php5_module "C:\Program Files\PHP\php5apache2_2.dll"

As a result some (all?) PHP extensions cannot be loaded by Apache. Yes, this is not entirely fault of PHP, but I'm almost sure it used to be fine in previous versions.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-09 18:46 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: cmb
 [2015-06-09 18:46 UTC] cmb@php.net
This ticket is obsolete, because Microsoft installer binaries
(.msi) are not distributed anymore as of PHP 5.4.0.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Oct 25 19:01:23 2020 UTC