php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54273 php-fpm SAPI fails to build on AIX 6.1 (on IBM POWER6 arch)
Submitted: 2011-03-16 14:12 UTC Modified: 2011-10-08 20:00 UTC
From: a dot sykes at ucl dot ac dot uk Assigned: fat (profile)
Status: Wont fix Package: FPM related
PHP Version: 5.3.5 OS: AIX 6.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: a dot sykes at ucl dot ac dot uk
New email:
PHP Version: OS:

 

 [2011-03-16 14:12 UTC] a dot sykes at ucl dot ac dot uk
Description:
------------
Attempting to build php with the php-fpm SAPI fails on AIX 6.1. It's clearly 
because the processor type isn't defined in php-5.3.5/sapi/fpm/fpm/fpm_atomic.h.

I have no idea what the appropriate typedefs for this architecture should be.

Additionally, I'm compiling with the IBM xlc compiler.

I can successfully compile every other part of PHP with my toolchain.

Output of uname -pM:

powerpc IBM,8203-E4A

(This is arch and machine model number - an IBM Power 520 Express)

PHP's configure line:

./configure \
    --cache-file=../config.cache \
    --prefix=/opt/freeware \
    --with-config-file-path=/opt/freeware/etc \
    --enable-shared --enable-static \
    --without-pear \
    --with-gd=/opt/freeware \
    --with-openssl=/opt/freeware \
    --with-zlib \
    --with-bz2 \
    --with-curl=/opt/freeware \
    --with-t1lib=/opt/freeware \
    --with-freetype-dir=/opt/freeware \
    --with-jpeg-dir=/opt/freeware \
    --with-png-dir=/opt/freeware \
    --with-xpm-dir=/opt/freeware \
    --with-zlib-dir=/opt/freeware \
    --enable-soap \
    --enable-bcmath \
    --enable-ftp \
    --with-iconv \
    --enable-dom \
    --enable-json \
    --with-pcre-regex=/opt/freeware \
    --enable-fpm


End of the compile output:

/opt/freeware/bin/bash /opt/freeware/src/packages/BUILD/php-5.3.5/build-php-
fpm/libtool --silent --preserve-dup-deps --mode=compile xlc -
I/opt/freeware/src/packages/BUILD/php-5.3.5/sapi/fpm -Isapi/fpm/ -
I/opt/freeware/src/packages/BUILD/php-5.3.5/sapi/fpm/ -DPHP_ATOM_INC -
I/opt/freeware/src/packages/BUILD/php-5.3.5/build-php-fpm/include -
I/opt/freeware/src/packages/BUILD/php-5.3.5/build-php-fpm/main -
I/opt/freeware/src/packages/BUILD/php-5.3.5 -
I/opt/freeware/src/packages/BUILD/php-5.3.5/build-php-fpm/ext/date/lib -
I/opt/freeware/src/packages/BUILD/php-5.3.5/ext/date/lib -
I/opt/freeware/src/packages/BUILD/php-5.3.5/ext/ereg/regex -
I/opt/freeware/include/libxml2 -I/opt/freeware/include -
I/opt/freeware/include/freetype2 -I/opt/freeware/src/packages/BUILD/php-
5.3.5/ext/sqlite3/libsqlite -I/opt/freeware/src/packages/BUILD/php-5.3.5/build-
php-fpm/TSRM -I/opt/freeware/src/packages/BUILD/php-5.3.5/build-php-fpm/Zend -
I/opt/freeware/src/packages/BUILD/php-5.3.5/main -
I/opt/freeware/src/packages/BUILD/php-5.3.5/Zend -
I/opt/freeware/src/packages/BUILD/php-5.3.5/TSRM -
I/opt/freeware/src/packages/BUILD/php-5.3.5/build-php-fpm/    -I/usr/include -
qmaxmem=16384 -DSYSV -D_AIX -D_AIX32 -D_AIX41 -D_AIX43 -D_AIX51 -D_AIX52 -
D_AIX53 -D_AIX61 -D_ALL_SOURCE -DFUNCPROTO=15 -O -I/opt/freeware/include  -c 
/opt/freeware/src/packages/BUILD/php-5.3.5/sapi/fpm/fpm/fpm_children.c -o 
sapi/fpm/fpm/fpm_children.lo
"/opt/freeware/src/packages/BUILD/php-5.3.5/Zend/zend.h", line 179.10: 1506-236 
(W) Macro name __restrict__ has been redefined.
"/opt/freeware/src/packages/BUILD/php-5.3.5/Zend/zend.h", line 179.10: 1506-358 
(I) "__restrict__" is defined on line 186 of /usr/include/standards.h.
"/opt/freeware/src/packages/BUILD/php-5.3.5/sapi/fpm/fpm/fpm_atomic.h", line 
142.2: 1506-205 (S) #error Unsupported processor. Please open a bug report 
(bugs.php.net).
"/opt/freeware/src/packages/BUILD/php-5.3.5/sapi/fpm/fpm/fpm_atomic.h", line 
146.41: 1506-277 (S) Syntax error: possible missing ')' or ','?
"/opt/freeware/src/packages/BUILD/php-5.3.5/sapi/fpm/fpm/fpm_atomic.h", line 
149.39: 1506-045 (S) Undeclared identifier lock.
"/opt/freeware/src/packages/BUILD/php-5.3.5/sapi/fpm/fpm/fpm_shm_slots.h", line 
16.17: 1506-046 (S) Syntax error.
gmake: *** [sapi/fpm/fpm/fpm_children.lo] Error 1

Expected result:
----------------
php compiles with the php-fpm.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-03-16 14:37 UTC] a dot sykes at ucl dot ac dot uk
Should've mentioned that I've looked at the patch in this bug: 
http://bugs.php.net/bug.php?id=51772

But it doesn't seem relevant against PHP 5.3.5. I'd be happy to test (and 
stability test) any patch.
 [2011-06-13 02:29 UTC] felipe@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: fat
 [2011-10-08 20:00 UTC] fat@php.net
Hi,

gcc >= 4.4.1 have all needed to compile atomic function. Can't you compile PHP 
with this ?

I'm sorry, but I can't make a patch for your arch and compiler as I don't have any 
of them nor the skills. Sorry :(
 [2011-10-08 20:00 UTC] fat@php.net
-Status: Assigned +Status: Wont fix
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC