php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54267 Receiving notice "Uninitialized string offset" as fatal error under Zend
Submitted: 2011-03-16 05:23 UTC Modified: 2011-03-16 05:27 UTC
From: jbarbuto at gmail dot com Assigned:
Status: Not a bug Package: Strings related
PHP Version: 5.2SVN-2011-03-16 (SVN) OS: Ubuntu 10.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jbarbuto at gmail dot com
New email:
PHP Version: OS:

 

 [2011-03-16 05:23 UTC] jbarbuto at gmail dot com
Description:
------------
Hi,

Despite having "error_reporting = E_ALL & ~E_NOTICE" in php.ini, we found the 
following notice was being reported as a fatal error with a ZendGuard-encoded 
script we were running under php 5.2.14: 

Fatal error in line 111 of file/foo.php
- Uninitialized string offset: 35918

We found the error didn't appear with php < 5.2.10.  Further investigation found 
the change introduced in SVN revision 278340 was the cause; 
reverting it in the 5.2 branch fixed the problem for us.  Perhaps there's 
something in this patch that needs tweaking?

Thanks,
John


Patches

svn-r278340-diff (last revision 2011-03-16 04:25 UTC by jbarbuto at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-03-16 05:27 UTC] rasmus@php.net
-Status: Open +Status: Bogus
 [2011-03-16 05:27 UTC] rasmus@php.net
We can't support non-PHP extensions here.

If you can reproduce the bug in a clean PHP script against PHP 5.3.x, feel free to 
re-open the bug.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Oct 25 09:01:23 2020 UTC