php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54260 7+SP1 shows as unknown os
Submitted: 2011-03-15 23:30 UTC Modified: 2011-07-01 12:35 UTC
Votes:3
Avg. Score:2.7 ± 1.2
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:3 (100.0%)
From: bigaloguy at gmail dot com Assigned:
Status: Closed Package: Win32API related
PHP Version: 5.3.6RC3 OS: Windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bigaloguy at gmail dot com
New email:
PHP Version: OS:

 

 [2011-03-15 23:30 UTC] bigaloguy at gmail dot com
Description:
------------
Directly from phpinfo():

System 	Windows NT BIG-PC 6.1 build 7601 (Unknow Windows version Ultimate Edition Service Pack 1) i586
Build Date 	Mar 10 2011 13:15:16
Compiler 	MSVC9 (Visual C++ 2008) 

Test script:
---------------
<?php
phpinfo();
?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-07-01 12:35 UTC] bigaloguy at gmail dot com
-Status: Open +Status: Closed
 [2011-07-01 12:35 UTC] bigaloguy at gmail dot com
Fixed in 5.4.0alpha1.
Now shows:
Windows NT BIG-PC 6.1 build 7601 (Windows 7 Ultimate Edition Service Pack 1) i586
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Sep 27 19:05:52 2022 UTC