php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54188 php cannot load interbase/firebird module including pdo.
Submitted: 2011-03-08 01:53 UTC Modified: 2011-03-11 18:43 UTC
From: jacobswell4u at yahoo dot com Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 5.3.5 OS: win7 & winxp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jacobswell4u at yahoo dot com
New email:
PHP Version: OS:

 

 [2011-03-08 01:53 UTC] jacobswell4u at yahoo dot com
Description:
------------
to load firebird module I changed php.ini

extension=php_interbase.dll
extension=php_pdo_firebird.dll

before you start php, you have to prepare dll files because PHP release zip file 
does not have these dll any more. When starting, php gives two errors:

(I copied fbclient.dll from firebird 2.5 to php directory and Apache's bin 
directory.)

1. cannot load php_interbase.dll.

2. cannot load php_pdo_firebird.dll becuase it requires php_pdo.dll. but to me 
5.3.5 has pdo support in itself!

so I had to use the old 5.3.1 version.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-03-08 05:40 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2011-03-08 05:40 UTC] pajoye@php.net
You have to install fbclient 2.5, that's expected.

Pdo_firebird loads just fine, PDO is builtin in PHP, there is no need to enable 
php_pdo.dll. Are you sure that you did not mix versions?
 [2011-03-11 17:42 UTC] jacobswell4u at yahoo dot com
Yes, I have installed firebird 2.5. The firebird extension works fine with php 
5.3.1. I have tested php 5.3.5 with php_interbase.dll which can be downloaded from 
firebird-php groups.yahoo.com, and the server could not load the extension dll. I 
believe the problem is in php 5.3.5.

And about the pdo extension. I do know the pdo is built-in. I could not get 
php_pdo_firebird.dll from php.net, so I tested with the dll from php 5.3.1. and it 
gives error that php cannot find the php_pdo.dll. should I use new 
php_pdo_firebird.dll made for php 5.3.5 or can I use from php 5.3.1? We have php 
5.3 and why is there big change between them?
 [2011-03-11 18:43 UTC] pajoye@php.net
-Status: Feedback +Status: Bogus
 [2011-03-11 18:43 UTC] pajoye@php.net
5.3.1 did not have firebird so no, it can't have worked fine. Your config is 
somehow broken (PATH or something along this line).
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 25 20:01:29 2020 UTC