php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54071 dir_opendir does not return handle but bool
Submitted: 2011-02-22 17:28 UTC Modified: 2011-02-23 17:02 UTC
From: ghosh at q-one dot com Assigned:
Status: Not a bug Package: Streams related
PHP Version: 5.3.5 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ghosh at q-one dot com
New email:
PHP Version: OS:

 

 [2011-02-22 17:28 UTC] ghosh at q-one dot com
Description:
------------
In contrast to "opendir", streamWrapper::dir_opendir does not return a handle but a bool. This is bad IMHO, because within a call of dir_readdir there seems to be no way to differentiate which directory is currently being read in case multiple dir_opendir-calls are running concurrently.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-22 18:11 UTC] ghosh at q-one dot com
-Status: Open +Status: Closed
 [2011-02-22 18:11 UTC] ghosh at q-one dot com
Sorry. This is bogus. Found this out myself: streamWrapper is being called as a separate object instance for each running opendir. Should perhaps be documented a bit more. Documentation on all this is really sparse at the moment.
 [2011-02-23 17:02 UTC] cataphract@php.net
-Status: Closed +Status: Bogus
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 21:03:39 2021 UTC