php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54049 output_buffering enabled by default in development configuration
Submitted: 2011-02-18 21:16 UTC Modified: 2012-03-04 17:38 UTC
From: chealer at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.3.5 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chealer at gmail dot com
New email:
PHP Version: OS:

 

 [2011-02-18 21:16 UTC] chealer at gmail dot com
Description:
------------
output_buffering is Off by default, but not with the development profile:

; output_buffering
;   Default Value: Off
;   Development Value: 4096
;   Production Value: 4096

I understand why output buffering is enabled in production, however I can't see a reason why it would be disabled by default but enabled in development. I haven't found any rationale for this situation, but my impression is that this is a bug.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-04 17:38 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2012-03-04 17:38 UTC] rasmus@php.net
This isn't a bug. The idea here is that you should know if you are turning on 
output buffering since there can be some side effects as described in the sample 
ini files. Without an ini file, we play it safe and default it to off. If you use 
either the php.ini-development or php.ini-production files, chances are you have 
read through them and thus have some understanding of what you are enabling.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 04:05:46 2022 UTC